Jump to content
Hamer Fan Club Message Center

Recommended Posts

My favorite OD pedal bit the dust. It might be repairable but not by me. Having a tech do it, if I could find one  in this Godforsaken music desert, could be almost as expensive.

So, waddaya got?

  • Like 1
Link to post
Share on other sites

So many flavors of OD.....Which is your style?

I know there are many of us that have too many stashed in a drawer......

  • Like 1
Link to post
Share on other sites

If you pay for shipping you can have my Bad Monkey tube screamer flavored.

arniez

Edited by ArnieZ
  • Like 5
Link to post
Share on other sites

No extra overdrives right now, but if you want to send me your broken pedal I'll try to fix it and send it back;  Probably just a dirty switch or off-board solder point if you didn't kill it with extra voltage or something.

  • Like 8
Link to post
Share on other sites

I'm the rhythm player in our band, not too many solos. My current amps are both single channel; one Vox style and one Champ style.

Music is kinda classic rock, blues rock; Allman's, Aerosmith, J Giels, ZZ Top, Fabulous Thunderbirds, Savoy Brown, Cheap Trick, SRV, and starting some AC/DC.

Please don't suggest a different amp. Don't know if I want to go there yet.

  • Like 1
Link to post
Share on other sites
4 minutes ago, soli'd said:

No extra overdrives right now, but if you want to send me your broken pedal I'll try to fix it and send it back;  Probably just a dirty switch or off-board solder point if you didn't kill it with extra voltage or something.

Came here to say exactly this. What pedal is causing problems, and what are the symptoms? Extra noise? No sound when on? No output on or off? The HFC family is here to help!

  • Like 2
Link to post
Share on other sites

My Twimble Simble is killing my signal chain. No sound at all. If I tap it a few times it'll come back on line. Checked all amps, cables, power connections as well as the power supply. Took it out if the chain and no probs

  • Thanks 1
  • Sad 1
Link to post
Share on other sites
1 minute ago, rugby1970 said:

My Twimble Simble is killing my signal chain. No sound at all. If I tap it a few times it'll come back on line. Checked all amps, cables, power connections as well as the power supply. Took it out if the chain and no probs

Sounds like a bad switch or loose connection. 5 minute fix.

  • Thanks 1
Link to post
Share on other sites
Posted (edited)

My Twimble Simble is killing my signal chain. No sound at all. If I tap it a few times it'll come back on line. Checked all amps, cables, power connections as well as the power supply. Took it out if the chain and no probs

Edited by rugby1970
Screwed up
Link to post
Share on other sites
29 minutes ago, Biz Prof said:

Many thanks for looking out for me in my area, thanks. I have this exact pedal. It's what I use for a light gain flavor.

  • Like 2
Link to post
Share on other sites

just my 10 cents contribution, I just bought a Nobels ODR mini for less than 50 EUR as new, incredible bang for the buck, I definately would recommend it. 

I' m not selling mine but these are easy to find

  • Like 1
Link to post
Share on other sites

Buy a Barber! You'll never regret it! There's light gain to full metal assortment. All quiet, as in turn it on and no extra noise raising the noise floor. Just your guitar as you dialed it in!

  • Like 1
Link to post
Share on other sites
On 3/23/2021 at 4:56 PM, rugby1970 said:

Many thanks for looking out for me in my area, thanks. I have this exact pedal. It's what I use for a light gain flavor.

Me too.  a couple of others in my area are using it (and are happy with it) on my recommendation.

 

  • Like 1
Link to post
Share on other sites

UPDATE

I stripped down my entire pedal board and built it up again on a smaller scale on a smaller board, didn't use the Twimble and still had problems. Took off my old trem and reverb pedals. Changed out the tuner and still had problems (I'll have to fix the hole that punched in the wall of my office). Then I found a loose connection, installed a new set of power cables and voila, it works! So, I still have the bigger board with the Sonic Research tuner, Twimble, Mojo Mojo, and Memphis Sun (using reverb only right now).

But I'm still in the market for new pedals - never say never.

  • Haha 3
Link to post
Share on other sites

Those are not easy pedals to find. Definitely fix it if you really like it. It's almost certainly an easy fix.

Dual switch pedals like that are nice, and very versatile. Fulltone makes a bunch of great ones.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...